1

Topic: Add text form element to Toolbar

Hi everyone.

I'm setting up a blog and I tried to add a <input type="text"> form field into the toolbar to set the title entriy, as shown in the following screenshot: http://www.zimagez.com/zimage/capturadepantalla-290314-151617.php

I could do them with the 3.0 API successfully, but I can't do them with the 4.0 API. I searched everywhere in Google and look the Documentation, but them explains how to add only custom buttons, radios and menus, but not custom text fields with label. Also I tried to create a custom plug-in unsuccessfull (I don't a Javascript-specialist developer).

Anyone have already a 4.x API plug-in for them and their documentation? If not, where else can I find more documentation to develop such plug-in?

Thanks in advance.

2

Re: Add text form element to Toolbar

http://www.tinymce.com/wiki.php/Tutoria … g_a_plugin

3

Re: Add text form element to Toolbar

ceasar wrote:

http://www.tinymce.com/wiki.php/Tutorials:Creating_a_plugin

I already read the Create a plug-in tutorial, but the 4.0 API (or documentation) is too limited. So, I need deeper documentation, not a RTFM answer.

4

Re: Add text form element to Toolbar

Amitie10g wrote:

Hi everyone.

I'm setting up a blog and I tried to add a <input type="text"> form field into the toolbar to set the title entriy, as shown in the following screenshot: http://www.zimagez.com/zimage/capturadepantalla-290314-151617.php

I could do them with the 3.0 API successfully, but I can't do them with the 4.0 API. I searched everywhere in Google and look the Documentation, but them explains how to add only custom buttons, radios and menus, but not custom text fields with label. Also I tried to create a custom plug-in unsuccessfull (I don't a Javascript-specialist developer).

Anyone have already a 4.x API plug-in for them and their documentation? If not, where else can I find more documentation to develop such plug-in?

Thanks in advance.

How did you manage to set up the text input in 3.x API? I cannot find documentation anywhere for it considering 4.x API allows for 3.x compatibility.